AWS Global Outage impacting Atlassian Services and Mindpro Channels

Incident Report for Mindpro - Uptime & Status Page

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 09:31 GMT-03:00

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 11:11 GMT-03:00

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 11:06 GMT-03:00

Investigating

The Global AWS outage from Oct 20th (https://www.bbc.com/articles/cx275x61v6jo) is impacting some Atlassian products worldwide. Some of Mindpro's apps and channels are still impacted by this outage. Atlassian has applied a fix, but there are still some sites that are not fully operational yet, including Mindpro's (see more at https://developer.status.atlassian.com/).

At this moment, our Help Center is unstable and some pages and Support Portal are not available.

We are waiting for the fix on Atlassian's side to proceed with the necessary adjustments.
Posted Oct 21, 2025 - 11:05 GMT-03:00
This incident affected: Insights - Custom Charts, Reports, Dashboards for Jira, Sync - User Attributes (Azure AD, OKTA & Google) for Jira, Lineup - Service Management Queues for Jira & JSM, Deliver - Budget, Timesheets & Cost Tracker for Jira, Graphy - ITSM Charts, Reports, Dashboards for Jira & JSM, and Dashio - Agile Charts, Reports, & Dashboards for Jira.